MS-900 Describe Microsoft 365 apps and services • Complete Question Bank
Complete MS-900 Describe Microsoft 365 apps and services question bank — all 0 questions with answers and detailed explanations.
Drag steps to the numbered slots on the right, or tap a step then tap a slot.
Drag steps to the numbered slots on the right, or tap a step then tap a slot.
Drag steps to the numbered slots on the right, or tap a step then tap a slot.
Drag a concept onto its matching description — or click a concept then click the description.
Email and calendaring
Document management and intranet
Chat, meetings, and collaboration
Personal cloud storage and file sync
Drag a concept onto its matching description — or click a concept then click the description.
Intelligent recap and meeting transcripts
Microsoft Editor for grammar and style suggestions
Designer for slide layout recommendations
Focused Inbox and suggested replies
Drag a concept onto its matching description — or click a concept then click the description.
Service is available at least 99.9% of the time monthly
Discount on bill if SLA is not met
Scheduled downtime for updates
Minimum spend or term length in contract
{
"name": "CompanyPolicy",
"description": "Block external sharing for sensitive data",
"labels": ["Highly Confidential"],
"actions": {
"blockAccess": true,
"encrypt": true,
"applyWatermark": true
}
}Device Name: LAPTOP-1234 Compliance State: Non-compliant Last Check-in: 2026-03-10T14:30:00Z Primary User: user@contoso.com OS: Windows 11 Threat Level: High Jailbroken: No Encryption: Not Encrypted
{
"$schema": "https://schema.management.azure.com/schemas/2019-04-01/deploymentTemplate.json#",
"contentVersion": "1.0.0.0",
"resources": [
{
"type": "Microsoft.Storage/storageAccounts",
"apiVersion": "2021-02-01",
"name": "[parameters('storageAccountName')]",
"location": "[resourceGroup().location]",
"kind": "StorageV2",
"sku": {
"name": "Standard_LRS"
}
}
]
}Refer to the exhibit.
```json
{
"displayName": "Block access for non-Microsoft Entra ID users",
"state": "enabled",
"conditions": {
"applications": {
"includeApplications": ["Office365"]
},
"users": {
"includeUsers": ["All"]
}
},
"grantControls": {
"builtInControls": ["mfa", "compliantDevice"]
}
}
```Refer to the exhibit. ```powershell Get-Mailbox -Identity user@contoso.com | fl RetentionPolicy, LitigationHoldEnabled RetentionPolicy : LegalHoldPolicy LitigationHoldEnabled : True ```
Refer to the exhibit.
```json
{
"version": "1.0",
"rules": [
{
"name": "Block sensitive data sharing",
"condition": {
"sensitiveInformationTypes": [
{
"id": "Credit Card Number",
"confidenceLevel": "high"
}
]
},
"actions": {
"blockAccess": true,
"notifyUser": true
}
}
]
}
```{
"IsEnabled": true,
"Urls": ["https://contoso.sharepoint.com/sites/ProjectX"],
"BlockDownload": true,
"AccessType": "Block",
"IPRange": ["192.168.1.0/24"]
}{
"roleName": "Compliance Administrator",
"permissions": [
"microsoft.office365.securityComplianceCenter/allEntities/allTasks",
"microsoft.office365.protectionCenter/allEntities/allTasks"
]
}{
"displayName": "Block high-risk sign-ins",
"conditions": {
"signInRiskLevel": "high",
"applications": ["Office365"]
},
"grantControls": {
"builtInControls": ["block"]
}
}Refer to the exhibit.
```json
{
"displayName": "Copilot for Microsoft 365 rollout",
"assignedLicenses": [
{
"skuId": "cfq7ttc0k5g6",
"disabledPlans": ["Bing_Chat_Enterprise", "Teams_meeting_recordings"]
}
]
}
```Refer to the exhibit. ```kql EmailEvents | where Timestamp > ago(7d) | where EmailDirection == "Inbound" | where DeliveryAction == "Blocked" | summarize BlockedCount = count() by SenderDomain | top 10 by BlockedCount ```
{
"appliedIntents": ["encrypt", "watermark"],
"sensitivityLabelId": "S12345",
"encryption": {
"encryptedWith": "Microsoft Purview",
"protectionEnabled": true
},
"watermark": {
"text": "CONFIDENTIAL",
"visible": true
}
}Get-MgUser -Filter "userPrincipalName eq 'jdoe@contoso.com'" | Select-Object -Property DisplayName, UserPrincipalName, AssignedLicenses, UsageLocation
{
"$schema": "https://schema.management.azure.com/schemas/2019-04-01/deploymentTemplate.json#",
"resources": [
{
"type": "Microsoft.Storage/storageAccounts",
"name": "[parameters('storageName')]",
"apiVersion": "2021-02-01",
"location": "[resourceGroup().location]",
"kind": "StorageV2",
"sku": {
"name": "Standard_LRS"
}
}
]
}Refer to the exhibit.
{
"CopilotForM365": {
"Enabled": true,
"DataResidency": "EuropeanUnion",
"RestrictedContentSources": ["SharePoint", "OneDrive"],
"GraphConnectors": []
}
}Refer to the exhibit. Get-Mailbox -Identity user1@contoso.com | Select -ExpandProperty RetainDeletedItemsFor
Refer to the exhibit.
{
"properties": {
"displayName": "Sales Team",
"description": "Team for Sales department",
"visibility": "private",
"classification": "Confidential",
"specialization": "none",
"isMembershipLimitedToOwners": true
}
}Refer to the exhibit.
{
"assignment": {
"target": {
"group": "Group_Sales"
},
"settings": [
{
"settingId": "device_lock",
"value": {
"@odata.type": "#microsoft.graph.deviceCompliancePolicySettingState",
"setting": "requirePassword",
"settingName": "Require password to unlock mobile device",
"instanceDisplayName": "Require Password",
"state": "compliant"
}
},
{
"settingId": "encryption",
"value": {
"@odata.type": "#microsoft.graph.deviceCompliancePolicySettingState",
"setting": "requireEncryption",
"settingName": "Require encryption on device",
"instanceDisplayName": "Require Encryption",
"state": "notCompliant"
}
}
]
}
}Refer to the exhibit.
{
"tenantId": "contoso.onmicrosoft.com",
"displayName": "Contoso",
"roles": [
{
"roleName": "User Administrator",
"assignments": [
{
"principalId": "user1@contoso.com",
"assignmentType": "Active"
}
]
},
{
"roleName": "Global Administrator",
"assignments": [
{
"principalId": "user2@contoso.com",
"assignmentType": "Eligible"
}
]
}
]
}Refer to the exhibit.
$policies = Get-ComplianceTag
foreach ($policy in $policies) {
if ($policy.RetentionAction -eq "Delete") {
Write-Host "Policy $($policy.Name) will delete data after $($policy.RetentionDuration) days"
}
}Refer to the exhibit.
```json
{
"displayName": "Contoso AI Policy",
"description": "Policy to restrict Copilot data access",
"mode": "advanced",
"rules": [
{
"type": "sensitiveInformation",
"sensitiveInformationType": "CreditCardNumber",
"confidenceLevel": "high",
"action": "blockAccess"
}
]
}
```Refer to the exhibit. ``` $TeamsMeetingPolicy = Get-CsTeamsMeetingPolicy -Identity "Global" $TeamsMeetingPolicy.AllowTranscription = $True $TeamsMeetingPolicy.AllowRecording = $True Set-CsTeamsMeetingPolicy -Instance $TeamsMeetingPolicy ```
Refer to the exhibit.
```xml
<Policy Id="Contoso-ConditionalAccess">
<Conditions>
<Users>
<Include>
<AllUsers></AllUsers>
</Include>
</Users>
<Applications>
<Include>
<AppId>00000003-0000-0ff1-ce00-000000000000</AppId>
</Include>
</Applications>
</Conditions>
<GrantControls>
<RequireMFA>true</RequireMFA>
</GrantControls>
</Policy>
```{
"policy": {
"name": "Block External Sharing",
"type": "SharePoint Online Sharing Policy",
"sharingCapability": "Disabled",
"allowExternalSharing": false,
"externalUserExpirationInDays": 30
}
}Security & Compliance PowerShell:
Get-ComplianceTag | Where-Object {$_.RetentionAction -eq "KeepAndDelete" -and $_.RetentionDuration -gt 365}{
"properties": {
"displayName": "Contoso Marketing Campaign",
"description": "Campaign assets and documents",
"webUrl": "https://contoso.sharepoint.com/sites/MarketingCampaign",
"siteCollection": {
"hostname": "contoso.sharepoint.com",
"root": { "webTempate": "GROUP#0" }
}
}
}Refer to the exhibit.
```json
{
"displayName": "Policy: Mark emails from external senders as external",
"priority": 1,
"conditions": {
"fromScope": "NotInOrganization"
},
"actions": {
"prependSubject": "[External] "
},
"mode": "Enforce"
}
```Refer to the exhibit.
```json
{
"complianceTag": "Confidential",
"autoLabeling": {
"sensitiveInfoTypes": ["Credit Card Number"],
"location": "SharePoint",
"minConfidence": 75
},
"protection": {
"encryption": "Encrypt-Only"
}
}
```{
"policies": [
{
"name": "BlockHighRiskSignIns",
"conditions": {
"riskLevel": "high"
},
"grantControls": {
"builtInControls": ["block"]
}
},
{
"name": "RequireMFAForAll",
"conditions": {
"users": ["All"],
"applications": ["All"]
},
"grantControls": {
"builtInControls": ["mfa"]
}
}
]
}Refer to the exhibit.
```json
{
"identityProtection": {
"userRiskPolicy": {
"enabled": true,
"riskLevel": "medium",
"blockAccess": false
},
"signInRiskPolicy": {
"enabled": true,
"riskLevel": "high",
"blockAccess": true
}
}
}
```{
"AssignmentType": "AutoAssignment",
"Description": "Deploy Office to Windows 10 devices",
"Groups": [
{
"GroupId": "group-id-1",
"GroupName": "Contoso-Sales"
}
],
"Applications": [
{
"Id": "Microsoft.Office.365.ProPlusWin32",
"Name": "Microsoft 365 Apps for Enterprise"
}
]
}